PRODUCTS AND SERVICES REFERENCED HEREIN INCLUDING WITHOUT LIMITATION ANY OF THE FOLLOWING DAMAGES: DIRECT, CONSEQUENTIAL, EXEMPLARY, INCIDENTAL, INDIRECT, SPECIAL, PUNITIVE, OR AGGRAVATED DAMAGES, DAMAGES FOR LOSS OF PROFITS OR REVENUES, FAILURE TO REALIZE ANY EXPECTED SAVINGS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF BUSINESS OPPORTUNITY, OR CORRUPTION OR LOSS OF DATA, FAILURES TO TRANSMIT OR RECEIVE ANY DATA, PROBLEMS ASSOCIATED WITH ANY APPLICATIONS USED IN CONJUNCTION WITH RIM PRODUCTS OR SERVICES, DOWNTIME COSTS, LOSS OF THE USE OF RIM PRODUCTS OR SERVICES OR ANY PORTION THEREOF OR OF ANY AIRTIME SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF COVER, FACILITIES OR SERVICES, COST OF CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT SUCH DAMAGES WERE FORESEEN OR UNFORESEEN, AND EVEN IF RIM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, RIM SHALL HAVE NO OTHER OBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR OTHERWISE TO YOU INCLUDING ANY LIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.

THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE NATURE OF THE CAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO BREACH OF CONTRACT, NEGLIGENCE, TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND SHALL SURVIVE A FUNDAMENTAL BREACH OR BREACHES OR THE FAILURE OF THE ESSENTIAL PURPOSE OF THIS AGREEMENT OR OF ANY REMEDY CONTAINED HEREIN; AND (B) TO RIM AND ITS AFFILIATED COMPANIES, THEIR SUCCESSORS, ASSIGNS, AGENTS, SUPPLIERS (INCLUDING AIRTIME SERVICE PROVIDERS), AUTHORIZED RIM DISTRIBUTORS (ALSO INCLUDING AIRTIME SERVICE PROVIDERS) AND THEIR RESPECTIVE DIRECTORS, EMPLOYEES AND INDEPENDENT CONTRACTORS.

IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY DIRECTOR, EMPLOYEE, AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF RIM OR ANY AFFILIATES OF RIM HAVE ANY LIABILITY ARISING FROM OR RELATED TO THE DOCUMENTATION.

Prior to subscribing for, installing or using any Third Party Products and Services it is your responsibility to ensure that your airtime service provider has agreed to support all of their features. Some airtime service providers may not offer Internet browsing functionality with a subscription to BlackBerry® Internet Service. Check with your service provider for availability, roaming arrangements, service plans and features. Installation or use of Third Party Products and Services with RIM’s products and services may require one or more patent, trademark, copyright or other licenses in order to avoid infringement or violation of third party rights. You are solely responsible for determining whether to use, Third Party Products and Services and if any third party licenses are required to do so. If required you are responsible for acquiring them. You should not install or use Third Party Products and Services until all necessary licenses have been acquired. Any Third Party Products and Services that are provided with RIM’s products and services are provided as a convenience to you and are provided “AS IS” with no express or implied conditions, endorsements, guarantees, representations or warranties of any kind by RIM and RIM assumes no liability whatsoever, in relation thereto. Your use of Third Party Products and Services shall be governed by and subject to you agreeing to the terms of separate licenses and other agreements applicable thereto with third parties, except to the extent expressly covered by a license or other agreement with RIM.

Certain features outlined in this documentation require a minimum version of BlackBerry® Enterprise Server software, BlackBerry® Desktop Software, and/or BlackBerry® Device Software and may require additional development or Third Party Products and Services for access to corporate applications.

This product includes software developed by the Apache Software Foundation (http://www.apache.org/) and/or licensed pursuant to Apache License, Version 2.0 (http://www.apache.org/licenses/). For more information, see the NOTICE.txt file included with the software. Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

The terms of use of any RIM product or service are set out in a separate license or other agreement with RIM applicable thereto. NOTHING IN THIS DOCUMENTATION IS INTENDED TO SUPERSEDE ANY EXPRESS WRITTEN AGREEMENTS OR WARRANTIES PROVIDED BY RIM FOR PORTIONS OF ANY RIM PRODUCT OR SERVICE OTHER THAN THIS DOCUMENTATION.
Chapter 7: BlackBerry themes and animated graphics

This chapter provides an overview of SVG and its significance when developing media applications for mobile devices. The chapter describes the two main methods you can use to create SVG: coding manually in a text editor or designing with a graphics editing tool. The chapter provides an overview of the Plazmic® Content Developer’s Kit and its two components: Plazmic Composer and Plazmic Theme Builder. The chapter also outlines the key features of Plazmic Composer, which you can use to create the following type of SVG content for mobile devices: interactive themes, mobile web sites, splash screens, graphics, and animations.
7.1 Create a custom Home screen graphic with interactive content using Plazmic Composer

In this exercise, you will use prepared graphics to create a custom Home screen background for a BlackBerry® Curve™ 8900 smartphone. You will add two interactive objects to your custom background.

1. To prepare for this exercise, review the video entitled How to create a Theme using Plazmic Theme Builder. From the BlackBerry Developer’s Zone web site, navigate to or search for the video entitled How to create a Theme using Plazmic Theme Builder.

2. Extract the BasicSVGThemeDeveloperLab_1.zip file.

3. Open Plazmic Composer.

4. On the File menu, click Open.

5. In the Open dialog box, browse to Home_Screen.svg, then click Open.

6. In the Layers pane, click the New Layer icon.

7. Right-click the new layer, and select Rename on the shortcut menu.

8. Enter the text Left Rock, and then press ENTER.

9. On the toolbar, click the Theme Button icon.

10. To insert the default Message icon, in the View window, click the bottom-left section of the graphic, inside the red circle.

11. In the Inspector, on the Properties tab, in the Launch Application section, in the drop-down list, click Calendar.

12. In the Images section, click the Normal thumbnail.

13. In the Open dialog box, browse to Rock_Red_Normal.png, and then click Open.

14. In the Images section, click the Focus thumbnail.

15. In the Open dialog box, browse to Rock_Red_Focus.png, and then click Open.

16. In the Inspector, click the Theme Button Animation tab.

17. In the Animation section, in the Focus In drop-down list, click Rotate -90.

18. In the Activate drop-down list, click Slide Up.
19. In the Layers pane, click the **New Layer** icon.

20. Right-click the new layer, and select **Rename** on the shortcut menu.

21. Enter the text **Right Rock**, then press ENTER.

22. On the toolbar, click the **Theme Button** icon.

23. To insert the default **Messages** icon, in the View window, click on the bottom-right section of the graphic, inside the blue circle.

24. In the Inspector, click the **Properties** tab.

25. In the **Launch Application** section, in the drop-down list, click **Camera**.

26. In the **Images** section, click the **Normal** thumbnail.

27. In the Open dialog box, browse to **Rock_Yellow_Normal.png**, and then click **Open**.

28. In the **Images** section, click the **Focus** thumbnail.

29. In the Open dialog box, browse to **Rock_Yellow_Focus.png**, and then click **Open**.

30. In the Inspector, click the **Theme Button Animation** tab.

31. In the **Animation** section, in the **Focus In** drop-down list, click **Quake**.

32. In the **Activate** drop-down list, click **Rotate 360**.

33. On the **File** menu, click **Save**.

34. In the Export to SVG dialog box, click **OK**.

35. On the **File** menu, click **Close**.

**Note:**

Use the Preview area to preview the functionality of your button animation. Roll over the thumbnail, and then click it to view the functionality.
7.2 Create a custom theme using Plazmic Theme Builder

In this exercise, you will build a custom curling theme for a BlackBerry Curve smartphone.

1. Open Plazmic Theme Builder.
2. To create a new theme, do the following:
   a. In the Create New Theme dialog box, in the Name field, type Curling.
   b. In the Device drop-down list, click 8900 Series (480x360).
   c. In the Type drop-down list, click custom.
   d. Click Create.
3. To customize the Home screen, do the following:
   a. Click the Theme the Home Screen Inspector.
   b. In the Applications pane, click the folder icon next to the SVG File field.
   c. In the Open dialog box, browse to Home_Screen.svg, and then click Open.
4. To customize the controls, do the following:
   a. Click the Theme the Controls Inspector.
   b. In the Dialog pane, click the box to the right of the Background thumbnail.
   c. In the Color Picker dialog box, on the RBG tab, in the Red field, type 236.
   d. In the Green field, type 209.
   e. In the Blue field, type 37.
   f. Click OK.
   g. In the Menu pane, click the Cursor box.
   h. In the Color Picker dialog box, on the RBG tab, in the Red field, type 121.
   i. In the Green field, type 112.
Chapter 7: BlackBerry themes and animated graphics

j. In the **Blue** field, type **239**.

k. Click **OK**.

l. In the Titlebar pane, click the **Cursor** box, and then repeat steps i to l.

m. In the List pane, click the **Cursor** box, and then repeat steps i to l.

n. In the List pane, click the **Multi-select** box.

o. In the Color Picker dialog box, on the **RBG** tab, in the **Red** field, type **82**.

p. In the **Green** field, type **75**.

q. In the **Blue** field, type **162**.

5. To customize the global items, do the following:

a. Click the **Theme Global items** Inspector.

b. In the Navigation pane, click the **Up** thumbnail.

c. In the Open dialog box, browse to **navigation_up_arrow.gif**, and then click **Open**.

d. In the Navigation pane, click the **Down** thumbnail.

e. In the Open dialog box, browse to **navigation_up_arrow.gif**, and then click **Open**.

f. In the Progress pane, in the **Complete** section, click the **Bar Color** box.

g. In the Color Picker dialog box, on the **RBG** tab, in the **Red** field, type **121**.

h. In the **Green** field, type **112**.

i. In the **Blue** field, type **239**.

j. Click **OK**.

6. To customize the active call screen, do the following:

a. Click the **Theme the Phone Screens** Inspector.

b. Click **Active Call**.

c. In the Active Call pane, click the **Background** thumbnail.

d. In the Open dialog box, browse to **Screen_ActiveCall.png**, and then click **Open**.

e. Click the **Font Color** box.
Chapter 7: BlackBerry themes and animated graphics

f. In the Color Picker dialog box, on the RBG tab, in the Red field, type 0.
g. In the Green field, type 0.
h. In the Blue field, type 0.
i. Click OK.

7. To customize the incoming call screen, do the following:
   a. In the Inspector, click Incoming Call.
   b. In the Incoming Phone Call pane, click the Background thumbnail.
   c. In the Open dialog box, browse to Screen_IncomingCall.png, and then click Open.
   d. Click the Font Color box.
   e. In the Color Picker dialog box, on the RBG tab, in the Red field, type 0.
   f. In the Green field, type 0.
   g. In the Blue field, type 0.
   h. Click OK.

8. To customize the lock screen, do the following:
   a. Click the Theme the Lockscreen Inspector.
   b. In the Lock Screen section, click the folder icon next to the SVG File field.
   c. In the Open dialog box, browse to Curling.svg, and then click Open.
   d. Click the Lock Icon thumbnail.
   e. In the Open dialog box, browse to Icon_LockScreen.png, and then click Open.

9. To customize the application icons, do the following:
   a. Click the Theme the Application Icons Screen Inspector.
   b. In the Home Screen section, click the Background thumbnail.
   c. In the Open dialog box, browse to Application_Icons.svg, and then click Open.
   d. In the Web Links pane, click Add Web Link.
   e. In the Web Link Properties dialog box, in the Name field, type World Curling.
f. In the Address field, type www.worldcurling.org.

g. Click OK.

h. Click the Normal thumbnail.

i. In the Open dialog box, browse to Icon_Normal.png, and then click Open.

j. Click the Focus thumbnail.

k. In the Open dialog box, browse to Icon_Focus.png, and then click Open.

10. To customize the BlackBerry smartphone navigation, do the following:

   a. Click the Theme the Home Screen Inspector.

   b. In the Navigation pane, click the left thumbnail.

   c. In the Applications dialog box, select the first application, and then click OK.

   d. In the Navigation pane, click the right thumbnail.

   e. In the Applications dialog box, select the second application, and then click OK.

   f. In the Navigation pane, click the down thumbnail.

   g. In the Applications dialog box, click Point nowhere, and then click OK.

11. On the File menu, click Save.

12. In the Save As dialog box, click Save.

13. In the Confirm Save As dialog box, click Yes.

14. On the main toolbar, click the Simulator icon. Use the BlackBerry Smartphone Simulator to verify that your theme functions properly.

   **Note:**
   You must download and install specific simulators before you can test your themes. For this exercise, the BlackBerry Smartphone Simulator has been downloaded for you. To download BlackBerry Smartphone Simulators, navigate to the BlackBerry Developer Zone website.

15. After you verify that your theme functions properly, close the BlackBerry Smartphone Simulator.

16. In Theme Builder, on the File menu, click Export.

17. In the Export dialog box, select the JAD option to enable users to download the theme from a web site to their BlackBerry smartphones over the wireless network.
18. Click the folder icon next to the Path field.

19. In the Select Export Location dialog box, browse to where you want to save the file, and then click OK.

20. Click OK.

Time permitting: Continue to explore the features of Plazmic Composer and Plazmic Theme Builder. Include some additional functionality to your theme. For example, add another interactive button to the center of your Home screen using the rock graphics.